Archiv für den Monat: Januar 2009

Boah, meine Nerven…

Großflächiger Stromausfall im Rechenzentrum und damit einhergehend ein Neustart diverser Server. Dazu der Ausfall eines RZ-Nameservers, wodurch die anderen Server auch nicht mehr flüssig liefen, sondern nur noch verzögert antworteteten. Das alleine wäre schon stressig genug gewesen, aber nein… Kabel BW meint 10 Minuten später, sie müssen auch noch einen Komplettausfall inkl. Telefon und Internet produzieren. Zum Glück gibt’s noch Handys und UMTS, sonst wäre ich im Kreis gelaufen.

Was tun, wenn das Internet „nur halb“ funktioniert

Da ich das Problem heute erst wieder hatte: ich sitze in einem fremden Netz, Zugang durch einen Tunnel (vpnc) und nur die Hälfte der Webseiten ist erreichbar. Ausserdem kann ich keine Mails versenden und auch keine abrufen. Ausser, sie sind sehr klein. Klarer Fall: auf dem Weg von mir bis zum Server gehen Pakete verloren. Also mal nachsehen: ifconfig aufrufen. Ich habe u.a. zwei Interfaces, nämlich eth0 (meine Netzwerkkarte) und tun0 (der Tunnel). eth0 hat eine MTU von 1460 und tun0 hat eine MTU von 1412. Aha. Die größten Pakete, die an einem Stück durchgehen sollten, sollten also 1412 Byte groß sein. Also mal ausprobieren, ob das denn auch so ist. Und zwar mit ping -s 1412 www.heise.de (oder jeder andere Host, welcher auf Pings antwortet). Und was passiert? Nichts. Da ist also der Fehler. Also probiert man weiter aus… ping -s 1300 www.heise.de geht, 1400 nicht, etc. Schnell ist klar, bei 1378 ist Schluss. Im Fall der Fälle muss man das natürlich selbst ausprobieren und kann nicht einfach 1378 nehmen. Um wieder alle Webseiten erreichen zu können, muss man nun die MTU umstellen, in meinem Fall auf 1378. Das geht für den Tunnel ganz einfach mit ifconfig tun0 mtu 1378. Und siehe da, ich habe das Internet reapriert. 😉 Diejenigen, die mich heute fluchen gehört haben, wissen auch, in welchem Netz das Problem war. 🙂

O2 und die Taktung

Eigentlich wollte ich hier nur postitives über O2 berichten, abgesehen von ein paar Kleinigkeiten, welche mal wieder nicht rund gelaufen sind. Und einen (durchwachsenen) Bericht über mein neues Nokia 5800 wollte ich auch abgeben. Nun sieht es jedoch so aus, dass ich (alleine schon aus Wut über die Inkompetenz von O2) das Handy nachher wieder einpacke und samt Vertragsunterlagen zurücksende.
Der Grund: ich wollte einen neuen Vertrag (ich war bisher Kunde bei Vodafone) mit einem Minutenpaket und einigen Zusatz-Optionen, u.a. eine 10/10-Taktung. Bei der Geschäftkunden(!)-Bestellhotline sagt man mir, das sei alles kein Problem. Die 10/10-Taktung würde 3 Euro extra kosten. Gestern kam nun das Handy, zusammen mit den Vertragunterlagen. Auf den Unterlagen stand dann allerdings als Taktung 60/10. Naja, dann hat der das halt falsch vermerkt; wird wohl kein Problem sein… ich also wieder angerufen – und erst einmal 20 Minuten in der Warteschlange gewartet (wieder Geschäftskunden-Bestellhotline). Dort sagte der Mitarbeiter mir jedoch, dass er das nur ändern könne, indem er mir eine komplett neue SIM-Karte zukommen lässt, die Vertragsdaten neu aufnimmt, etc. Viel einfacher wäre es, wenn ich die Karte aktiviere und danach die „normale“ Hotline anrufe. Nach der Aktivierung hatte ich auch gleich einen Hotline-Mitarbeiter dran. Und was erzählte der mir? Nein, eine 10/10-Taktung ist gar nicht möglich. Die gibt es nur bei Genion-Veträgen. Klassische Falschberatung also. Die einzigen Optionen die ich hätte sei, entweder den Vertrag nun so zu behalten oder alles wieder zurück zu senden. Das ganze wurde mir natürlich erst nach der Aktivierung gesagt. Mal sehen, ob mir daraus O2 nicht noch einen Strick drehen möchte… Wahrscheinlich werde ich nachher jedoch erst nochmal die Geschäftshotline anrufen und darauf bestehe, dass sie den Vertrag so erfüllen, wie sie ihn mir angeboten hatten (also mit 10/10-Taktung) und zudem meiner schlechten Laune Luft machen.

Logwatch

Irgend etwas mit Logwatch unter Gentoo stimmt nicht. Konkret habe ich für jeden überwachten Service vier verschiedene Konfigurationsdateien. Jedoch wird scheinbar nur eine davon ausgewertet.

Mich hat es schon lange aufgeregt, dass Logwatch erweiterte Log-Zeilen von vsftpd nicht versteht und mir diese deshalb als „Unmatched Entries“ ausgibt. Nun hab‘ ich endlich die richtige Zeile (und vor allem auch die richtige Datei) gefunden, mit dem ich Logwatch dieses Verhalten abgewöhnen kann:

In /usr/share/logwatch/default.conf/services/vsftpd.conf muss eine Zeile
$vsftpd_ignore_unmatched = 1

stehen. Ich freue mich schon auf kleinere Mails von Logwatch. Stellenweise waren die 45MB groß -> absolut kein Zustand. Wieso ich das überhaupt blogge? Ich sehe mich in 3 Wochen schon wieder nach dem richtigen Verzeichnis suchen…